Resolved
The issue is resolved and all systems are stable
Monitoring
Our authentication provider has fixed the issue and are monitoring it
Identified
Jack and Jill emails are still fully operational
Identified
Jill users might not see listed roles in their dashboard
Investigating
Our authentication provider is experiencing some issues, we are coordinating with them to get back to normal as soon as possible.