We have fixed the issue
Resolved
Investigating
Increased errors across the platform
Issue was resolved
We are experiencing degraded performance across both Jack and Jill